网络工程与系统集成期末考核

前言:

这是我老师布置的作业,花了我半天时间(还是个小菜鸡),就写了一下笔记,记录一下学习过

本文已收录进我的小破站chenyunzhi.top

在这里插入图片描述

一. 划vlan 配trunk

1.1 S-3700-A

[Huawei]port-group g10
[Huawei-port-group-g10]group-member e0/0/1 to e0/0/5
[Huawei-port-group-g10]port link-type access 
[Huawei-port-group-g10]port default vlan 10
[Huawei-port-group-g10]q
[Huawei]port-group g20
[Huawei-port-group-g20]group-member e0/0/6 to e0/0/10
[Huawei-port-group-g20]port link-type access
[Huawei-port-group-g20]port default vlan 20
[Huawei-port-group-g20]dis vlan
[Huawei]int g0/0/1
[Huawei-GigabitEthernet0/0/1]port link-type trunk
[Huawei-GigabitEthernet0/0/1]port trunk allow-pass vlan all	

1.2 S3700-B

[Huawei]port-group g10
[Huawei-port-group-g10]group-member e0/0/1 to e0/0/5
[Huawei-port-group-g10]port link-type access 
[Huawei-port-group-g10]port default vlan 10
[Huawei-port-group-g10]q
[Huawei]port-group g0
[Huawei-port-group-g20]group-member e0/0/6 to e0/0/10
[Huawei-port-group-g20]port link-type access
[Huawei-port-group-g20]port default vlan 30
[Huawei-port-group-g20]dis vlan
[Huawei]int g0/0/1
[Huawei-GigabitEthernet0/0/1]port link-type trunk
[Huawei-GigabitEthernet0/0/1]port trunk allow-pass vlan all	

三层交换机实现VLAN间通信

1.3 S5700

[Huawei]vlan batch 10 20 30 40 
[Huawei]int vlan 10
[Huawei-Vlanif1]ip address 192.88.6.254 24
[Huawei-Vlanif1]q
[Huawei]int vlan 20
[Huawei-Vlanif2]ip address 192.88.8.254 24
[Huawei]int vlan 30
[Huawei-Vlanif2]ip address 192.88.31.254 24
[Huawei-Vlanif2]q
[Huawei]int g0/0/23
[Huawei-GigabitEthernet0/0/1]port link-type trunk
[Huawei-GigabitEthernet0/0/1]port trunk allow-pass vlan all	
[Huawei]int g0/0/24
[Huawei-GigabitEthernet0/0/1]port link-type trunk
[Huawei-GigabitEthernet0/0/1]port trunk allow-pass vlan all		

然后ping一下看看pc机连通么

二.动态路由实现全网连通

AR2220-A、AR2220-B和AR2220-C路由器间 利用静态路由或动态路由协议实现全网互通。

2.1 S5700和AR2220-A之间的连通

配置连接路由器的接口和对应的VLANIF接口。

S5700

[Huawei] vlan batch 40
[Huawei] interface g0/0/1
[Huawei-GigabitEthernet0/0/1] port link-type access
[Huawei-GigabitEthernet0/0/1] port default vlan 40   
[Huawei-GigabitEthernet0/0/1] quit
[Huawei] interface vlanif 40
[Huawei-Vlanif40] ip address 192.168.40.2 24
[Huawei-Vlanif40] quit

配置动态路由

[Huawei]ospf 1
[Huawei-ospf-1]area 0
[Huawei-ospf-1-area-0.0.0.0]netwo	
[Huawei-ospf-1-area-0.0.0.0]network 192.88.40.0 0.0.0.255
[Huawei-ospf-1-area-0.0.0.0]network 192.88.8.0 0.0.0.255
[Huawei-ospf-1-area-0.0.0.0]network 192.88.6.0 0.0.0.255
[Huawei-ospf-1-area-0.0.0.0]network 192.88.31.0 0.0.0.255

注:配置路由才能使PC机和路由器连通

2.2 AR2220-A

[Huawei]int g0/0/0
[Huawei-GigabitEthernet0/0/0]ip address 192.168.50.1 24
[Huawei-GigabitEthernet0/0/0]int g0/0/1
[Huawei-GigabitEthernet0/0/1]ip address 192.168.40.1 24
[Huawei]dis ip interface brief 

动态路由:

[Huawei]ospf 1
[Huawei-ospf-1]area 0
[Huawei-ospf-1-area-0.0.0.0]network 192.88.40.0 0.0.0.255
[Huawei-ospf-1-area-0.0.0.0]network 192.88.50.0 0.0.0.255

2.3 AR2220-B

路由是没有s线的,需要自己配置

在这里插入图片描述

[Huawei]int g0/0/0
[Huawei-GigabitEthernet0/0/0]ip address 192.88.50.2 24
[Huawei-GigabitEthernet0/0/0]int g0/0/1
[Huawei-GigabitEthernet0/0/1]ip address 192.88.60.254 24
[Huawei]int s1/0/0
[Huawei-Serial1/0/0]ip address 210.18.10.1 24
[Huawei]ospf 1
[Huawei-ospf-1]area 0
[Huawei-ospf-1-area-0.0.0.0]network 192.88.50.0 0.0.0.255
[Huawei-ospf-1-area-0.0.0.0]network 192.88.60.0 0.0.0.255
[Huawei-ospf-1-area-0.0.0.0]network 210.18.10.0 0.0.0.255

测试pc1 ping 192.88.50.2

在这里插入图片描述

AR2220-C

[Huawei]int g0/0/0
[Huawei-GigabitEthernet0/0/0]ip address 210.18.11.1 24
[Huawei]int s1/0/0
[Huawei-Serial1/0/0]ip address 210.18.10.2 24
[Huawei]ospf 1
[Huawei-ospf-1]area 0
[Huawei-ospf-1-area-0.0.0.0]network 210.18.10.0 0.0.0.255
[Huawei-ospf-1-area-0.0.0.0]network 210.18.11.0 0.0.0.255

测试pc1 ping 210.18.10.2

在这里插入图片描述

三.配置ACL

根据以上拓扑划分的VLAN,在AR2220—B上配置ACL访问控制,要求VLAN10的主机 不能访问外网Internet

PC2目前可以连通外网

在这里插入图片描述

AR2220-B:指定规则ID为5,拒绝指定地址连通

[Huawei]acl 3000
[Huawei-acl-adv-3000]rule deny ip source 192.88.6.0 0.0.0.255 destination 210.18.10.0 0.0.0.255

[Huawei-acl-adv-3000]int g0/0/0
[Huawei-GigabitEthernet0/0/0]traffic-filter inbound acl 3000

#如果出现Error: A simplified ACL has been applied in this view.这种错误
[Huawei-GigabitEthernet0/0/1]undo traffic-filter inbound       #清理原有ACL

它没了

在这里插入图片描述

四.配置NAT和FTP服务

FTPServer1 可以访问外网Internet,但要在AR2220-B上配置静态NAT实现,具体映射为公网IP地址210.18.10.10。

int s1/0/0
nat server protocol tcp global 210.18.10.10 ftp inside 192.88.60.3 ftp
nat alg ftp enable
display nat server

这里配置nat有毛病,访问不上,不知道是不是命令问题还是软件问题,百度说用AR1220路由器可以实现,有时间的小伙伴试一下跟我说

在这里插入图片描述

在这里插入图片描述

在FTPServer1 上配置FTP服务

在AR2220-B上设置ftp登录的用户名和密码

[Huawei]aaa
[Huawei-aaa]local-user ftp password cipher 123456
Info: Add a new user.
[Huawei-aaa]local-user ftp ftp-directory flash:
[Huawei-aaa]local-user ftp service-type ftp
[Huawei-aaa]local-user ftp privilege level 15

创建一个文件夹,课本37页

在这里插入图片描述

在这里插入图片描述

在这里插入图片描述

五 .在client机器上登录测试

在这里插入图片描述

在这里插入图片描述

六.实验结果

1、在交换机S3700和S5700上分别运行下列命令:

 [S3700]display vlan 

在这里插入图片描述
在这里插入图片描述

[S5700] display ip interface brief

在这里插入图片描述

2、在路由器AR2220-A、AR2220-B和AR2220-C分别运行下列命令:

  [ AR2220] display ip route

在这里插入图片描述

   [ AR2220] display  ip interface brief

在这里插入图片描述

3、在AR2220–B上执行display nat static命令查看地址池映射关系。

在这里插入图片描述

4、在AR2220–B上执行display acl number(acl编号)
命令查看 访问控制列表ACL。

在这里插入图片描述

5、在PC1主机上分别ping PC5、 PC7主机,将测试结果截图写入设计报告

在这里插入图片描述

在这里插入图片描述

6、在FTPserver1主机上分别ping PC1、 PC7 主机,将测试结果截图写入设计报告
在这里插入图片描述
在这里插入图片描述

7、在PC1 上访问FTPserver1上的FTP服务,将测试结果截图写入设计报告。

在这里插入图片描述

本人博客:https://blog.csdn.net/weixin_46654114
本人b站求关注:https://space.bilibili.com/391105864
转载说明:跟我说明,务必注明来源,附带本人博客连接。

请给我点个赞鼓励我吧
在这里插入图片描述

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 博客之星2020 设计师:CY__ 返回首页